Back to overview
Downtime

singapore vps unreachable

May 24, 2026 at 10:19pm UTC
Affected services
main "server"
singapore server

Resolved
May 25, 2026 at 8:21am UTC

server have been restored!

Created
May 24, 2026 at 10:19pm UTC

due to excessive month bandwidth, our processing VPS was currently disabled by the hosting provider. currently looking up any solution.